注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

欢迎光临shaying110的博客

RSed-ISPing

 
 
 

日志

 
 

RIP配置  

2009-12-15 14:16:33|  分类: CISCO网络 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

 RIP配置 - shaying110 - shaying110的博客

 

hostname R1
!

ip subnet-zero

enab sec test
int lo0
ip add 10.100.1.1 255.255.255.255

!
interface FastEthernet0/0
no sh
 description link to R5-E1/0
 ip address 10.0.0.1 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet0/1
no sh
 description link to R2-E1/0
 ip address 10.0.0.5 255.255.255.252
 speed 10  /*注意接口速率的匹配*/
 full-duplex
!
router rip
 version 2 /*RIP版本的类型,V2支持变长子网*/
 network 10.0.0.0
!
ip classless /*无类路由*/

ip default-network 10.0.0.0 /*在RIP中,发布此默认路由*/


line vty 0 4    /*不使用密码直接telnet到特权模式*/

no login

privilege level 15


*********************************

hostname R2


enab sec test
int lo0
ip add 10.100.1.2 255.255.255.255


ip subnet-zero
no ip domain-lookup
!

!
!
interface Ethernet1/0
no sh
 description link to R1-FA0/1
 ip address 10.0.0.6 255.255.255.252
 full-duplex
!
interface Ethernet1/1
no sh
 description link to R3-E1/0
 ip address 10.0.0.10 255.255.255.252
 full-duplex
!
interface Ethernet1/2
no sh
 description link to R5-E1/1
 ip address 10.0.0.14 255.255.255.252
 full-duplex
!
interface Ethernet1/3
no sh
 description link to R4-FA0/1
 ip address 10.0.0.18 255.255.255.252
 full-duplex
!
router rip
 version 2
 network 10.0.0.0

!

ip route 10.0.0.0 255.0.0.0 10.0.0.16
!
ip classless
line vty 0 4
 no login
privilege level 15

************************


hostname R3

enab sec test
int lo0
ip add 10.100.1.3 255.255.255.255

ip subnet-zero
no ip domain-lookup
!
!
interface Ethernet1/0
no sh
 description link to R2-E1/1
 ip address 10.0.0.9 255.255.255.252
 full-duplex
!
interface Ethernet1/1
no sh
 description link to R5-FA0/0
 ip address 10.0.0.21 255.255.255.252
 full-duplex
!
interface Ethernet1/2
no sh
 description link to R5-E1/2
 ip address 10.0.0.25 255.255.255.252
 full-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
!
router rip
 version 2
 network 10.0.0.0
!
ip classless
line vty 0 4
 no login
privilege level 15

************************

hostname R4
!
enable secret test
!
!
!

ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 10.100.1.4 255.255.255.255
!
interface FastEthernet0/0
no sh
 description link to R3-E1/1
 ip address 10.0.0.22 255.255.255.252
 speed 10
 full-duplex
!
interface FastEthernet0/1
no sh
 description link to R2-E1/3
 ip address 10.0.0.17 255.255.255.252
 speed 10
 full-duplex
!
router rip
 version 2
 network 10.0.0.0
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 no login
privilege level 15


*************************

hostname R5
!

ip subnet-zero
no ip domain-lookup
!
!
!
enab sec test
int lo0
ip add 10.100.1.5 255.255.255.255

interface Ethernet1/0
no sh
 description link to R1-FA0/0
 ip address 10.0.0.2 255.255.255.252
 full-duplex
!
interface Ethernet1/1
no sh
 description link to R2-E1/2
 ip address 10.0.0.13 255.255.255.252
 full-duplex
!
interface Ethernet1/2
no sh
 description link to R3-E1/2
 ip address 10.0.0.26 255.255.255.252
 full-duplex
!
interface Ethernet1/3
no sh
 description link to SW
 ip address 10.11.1.1 255.255.255.0
 full-duplex
!
router rip
 version 2
 network 10.0.0.0
!
ip classless
line vty 0 4
 no login
privilege level 15

***************************

R1#sh ip route
Gateway of last resort is not set

 *   10.0.0.0/8 is variably subnetted, 13 subnets, 3 masks
R       10.11.1.0/24 [120/1] via 10.0.0.2, 00:00:04, FastEthernet0/0
R       10.0.0.8/30 [120/1] via 10.0.0.6, 00:00:07, FastEthernet0/1
R       10.0.0.12/30 [120/1] via 10.0.0.2, 00:00:04, FastEthernet0/0
                     [120/1] via 10.0.0.6, 00:00:07, FastEthernet0/1
C       10.0.0.0/30 is directly connected, FastEthernet0/0
C       10.0.0.4/30 is directly connected, FastEthernet0/1
R       10.0.0.24/30 [120/1] via 10.0.0.2, 00:00:04, FastEthernet0/0
R       10.0.0.16/30 [120/1] via 10.0.0.6, 00:00:07, FastEthernet0/1
R       10.0.0.20/30 [120/2] via 10.0.0.6, 00:00:07, FastEthernet0/1
                     [120/2] via 10.0.0.2, 00:00:04, FastEthernet0/0
R       10.100.1.5/32 [120/1] via 10.0.0.2, 00:00:04, FastEthernet0/0
R       10.100.1.4/32 [120/2] via 10.0.0.6, 00:00:07, FastEthernet0/1
R       10.100.1.3/32 [120/2] via 10.0.0.6, 00:00:11, FastEthernet0/1
                      [120/2] via 10.0.0.2, 00:00:08, FastEthernet0/0
R       10.100.1.2/32 [120/1] via 10.0.0.6, 00:00:11, FastEthernet0/1
C       10.100.1.1/32 is directly connected, Loopback0

*********************************************

R2#sh ip route
Gateway of last resort is 10.0.0.5 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 14 subnets, 4 masks
R       10.11.1.0/24 [120/1] via 10.0.0.13, 00:00:20, Ethernet1/2
C       10.0.0.8/30 is directly connected, Ethernet1/1
C       10.0.0.12/30 is directly connected, Ethernet1/2
S       10.0.0.0/8 [1/0] via 10.0.0.16
R       10.0.0.0/30 [120/1] via 10.0.0.5, 00:00:00, Ethernet1/0
                    [120/1] via 10.0.0.13, 00:00:20, Ethernet1/2
C       10.0.0.4/30 is directly connected, Ethernet1/0
R       10.0.0.24/30 [120/1] via 10.0.0.9, 00:00:10, Ethernet1/1
                     [120/1] via 10.0.0.13, 00:00:20, Ethernet1/2
C       10.0.0.16/30 is directly connected, Ethernet1/3
R       10.0.0.20/30 [120/1] via 10.0.0.9, 00:00:10, Ethernet1/1
                     [120/1] via 10.0.0.17, 00:00:11, Ethernet1/3
R       10.100.1.5/32 [120/1] via 10.0.0.13, 00:00:02, Ethernet1/2
R       10.100.1.4/32 [120/1] via 10.0.0.17, 00:00:20, Ethernet1/3
R       10.100.1.3/32 [120/1] via 10.0.0.9, 00:00:19, Ethernet1/1
C       10.100.1.2/32 is directly connected, Loopback0
R       10.100.1.1/32 [120/1] via 10.0.0.5, 00:00:09, Ethernet1/0
R*   0.0.0.0/0 [120/1] via 10.0.0.5, 00:00:09, Ethernet1/0
R2#

 

 

  评论这张
 
阅读(533)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018