注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

欢迎光临shaying110的博客

RSed-ISPing

 
 
 

日志

 
 

EIGRP和RIP的简单再发布配置  

2009-12-18 14:01:19|  分类: CISCO网络 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

EIGRP和RIP的简单再发布配置 - shaying110 - shaying110的博客

在这里,A和B运行EIGRP,而C只能运行RIP

故只能在B上配置EIGRP和RIP,然后再相互发布,保证整个网络的互通。具体配置如下:

Lab A

ip classless

ip subnet-zero

interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.2.1 255.255.255.248
!
interface Loopback2
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback3
 ip address 10.10.10.1 255.255.255.0
!        
interface FastEthernet0/0
 description link to R2-fa0/0

no sh
 ip address 10.3.1.1 255.255.255.0
 duplex full

router eigrp 100

net 0.0.0.0

no auto-summary

***************************************

Lab B

 

ip classless

ip subnet-zero

interface Loopback0
 ip address 192.168.4.1 255.255.255.128
!
interface Loopback1
 ip address 192.168.5.1 255.255.255.192
!
interface Loopback2
 ip address 172.16.50.1 255.255.255.240
!
interface Loopback3
 ip address 10.20.20.1 255.255.255.128
!
interface FastEthernet0/0
 ip address 10.3.1.2 255.255.255.0
 duplex full
!
interface FastEthernet1/0
 ip address 10.3.2.1 255.255.255.0
 duplex full
 speed auto
!
interface FastEthernet1/1
 no ip address
 duplex full
 speed auto
!
router eigrp 100
 redistribute rip metric 100000 100 255 1 1500
 network 0.0.0.0
 no auto-summary
!
router rip
 version 2
 redistribute eigrp 100 metric 7
 network 10.0.0.0
 no auto-summary

LAB C:

ip classless

ip subnet-zero

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
 ip address 8.8.8.1 255.255.255.224
!
interface Loopback3
 ip address 10.100.100.17 255.255.255.240
!
interface Loopback7
 ip address 8.9.0.1 255.255.255.240
!        
interface Loopback11
 ip address 18.200.1.241 255.255.255.240 

interface FastEthernet1/0
 ip address 10.3.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router rip
 version 2
 network 5.0.0.0
 network 8.0.0.0
 network 10.0.0.0
 network 18.0.0.0
 network 0.0.0.0
 no auto-summary

******************************************************

注意关闭RIP中的自动汇聚。

******************************************************

下面看一下各路由器上的路由表:

R1#sh ip route eig
     18.0.0.0/28 is subnetted, 1 subnets
D EX    18.200.1.240 [170/53760] via 10.3.1.2, 00:04:49, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
D EX    5.5.5.5 [170/53760] via 10.3.1.2, 00:04:49, FastEthernet0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.50.0/28 [90/156160] via 10.3.1.2, 00:04:49, FastEthernet0/0
     8.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D EX    8.9.0.0/28 [170/53760] via 10.3.1.2, 00:04:49, FastEthernet0/0
D EX    8.8.8.0/27 [170/53760] via 10.3.1.2, 00:04:49, FastEthernet0/0
     192.168.4.0/25 is subnetted, 1 subnets
D       192.168.4.0 [90/156160] via 10.3.1.2, 00:04:49, FastEthernet0/0
     192.168.5.0/26 is subnetted, 1 subnets
D       192.168.5.0 [90/156160] via 10.3.1.2, 00:04:49, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
D       10.20.20.0/25 [90/156160] via 10.3.1.2, 00:04:49, FastEthernet0/0
D       10.3.2.0/24 [90/30720] via 10.3.1.2, 00:04:49, FastEthernet0/0
D EX    10.100.100.16/28 [170/53760] via 10.3.1.2, 00:04:50, FastEthernet0/0
R1#

有标志为“D EX”的路由器3上的路由条目,这是在路由器上通过再发布RIP学习到的。

**************************************************************

R2#sh ip route rip
     18.0.0.0/28 is subnetted, 1 subnets
R       18.200.1.240 [120/1] via 10.3.2.2, 00:00:08, FastEthernet1/0
     5.0.0.0/32 is subnetted, 1 subnets
R       5.5.5.5 [120/1] via 10.3.2.2, 00:00:08, FastEthernet1/0
     8.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       8.9.0.0/28 [120/1] via 10.3.2.2, 00:00:08, FastEthernet1/0
R       8.8.8.0/27 [120/1] via 10.3.2.2, 00:00:08, FastEthernet1/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
R       10.100.100.16/28 [120/1] via 10.3.2.2, 00:00:08, FastEthernet1/0
R2#sh ip route eig
R2#sh ip route eigrp
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.1.0/24 [90/156160] via 10.3.1.1, 00:02:36, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
D       10.10.10.0/24 [90/156160] via 10.3.1.1, 00:02:36, FastEthernet0/0
D    192.168.1.0/24 [90/156160] via 10.3.1.1, 00:02:36, FastEthernet0/0
     192.168.2.0/29 is subnetted, 1 subnets
D       192.168.2.0 [90/156160] via 10.3.1.1, 00:02:36, FastEthernet0/0

在RIP中,将EIGRP 100再发布时度量值设为了7,注意在3上查看RIP路由信息。

*****************************************************************

R3#sh ip route rip
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
R       172.16.50.0/28 [120/7] via 10.3.2.1, 00:00:17, FastEthernet1/0
R       172.16.1.0/24 [120/7] via 10.3.2.1, 00:00:17, FastEthernet1/0
     192.168.4.0/25 is subnetted, 1 subnets
R       192.168.4.0 [120/7] via 10.3.2.1, 00:00:17, FastEthernet1/0
     192.168.5.0/26 is subnetted, 1 subnets
R       192.168.5.0 [120/7] via 10.3.2.1, 00:00:17, FastEthernet1/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
R       10.3.1.0/24 [120/1] via 10.3.2.1, 00:00:17, FastEthernet1/0
R       10.20.20.0/25 [120/1] via 10.3.2.1, 00:00:17, FastEthernet1/0
R       10.10.10.0/24 [120/7] via 10.3.2.1, 00:00:17, FastEthernet1/0
R    192.168.1.0/24 [120/7] via 10.3.2.1, 00:00:17, FastEthernet1/0
     192.168.2.0/29 is subnetted, 1 subnets
R       192.168.2.0 [120/7] via 10.3.2.1, 00:00:17, FastEthernet1/0
R3#注意度量值为7的路由条目,这是通过在路由器2上再发布EIGRP得到的

 

 

  评论这张
 
阅读(230)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017