注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

欢迎光临shaying110的博客

RSed-ISPing

 
 
 

日志

 
 

OSPF distribute-list与route-map过滤路由  

2011-11-28 20:06:32|  分类: CISCO网络 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
OSPF distribute-list与route-map过滤路由 - shaying110 - 欢迎光临shaying110的博客

 1、distribute-list 在OSPF进程下的in interface方向,只过滤入口路由并只影响本身的路由,但并不过滤LSA

 

2、distribute-list 在OSPF进程下的out方向,过滤LSA,路由表从本路由器开始受到影响


3、在路由进程下使用route-map时,过滤LSA,路由表从本路由器开始受到影响

如上图所示:

基本配置如下:

基本配置
R1:
interface Loopback0
 ip address 10.10.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.11.1.1 255.255.255.255
!
interface Loopback2
 ip address 10.12.1.1 255.255.255.255
!
interface Loopback3
 ip address 10.13.1.1 255.255.255.255
 
 interface FastEthernet0/1
 ip address 10.10.12.1 255.255.255.0
 
 router ospf 100
 log-adjacency-changes
 redistribute connected subnets
 network 10.10.1.1 0.0.0.0 area 0
 network 10.10.12.1 0.0.0.0 area 0
 
 ip access-list standard deny-conn
 deny   10.11.1.1
 deny   10.12.1.1
 permit any
!
!
!
route-map conn permit 10
 match ip address deny-conn
 
 R2:
 interface Loopback0
 ip address 10.10.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.10.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.10.23.2 255.255.255.0
 duplex auto
 
 router eigrp 100
 network 10.10.2.2 0.0.0.0
 network 10.10.23.2 0.0.0.0
 no auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 10.10.2.2 0.0.0.0 area 0
 network 10.10.12.2 0.0.0.0 area 0
 network 10.10.23.2 0.0.0.0 area 0
!
!
!
ip http server
no ip http secure-server
!
ip access-list standard deny-conn
 deny   10.11.1.1
 deny   10.12.1.1
 permit any
ip access-list standard deny-eigrp
 deny   10.4.1.0 0.0.0.255
 deny   10.4.2.0 0.0.0.255
 permit any
!
!
!
route-map deny-eigrp permit 10
 match ip address deny-eigrp


R3:

interface Loopback0
 ip address 10.10.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.10.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.10.34.3 255.255.255.0
 duplex auto
 
 router eigrp 100
 network 0.0.0.0
 no auto-summary
!
router ospf 100
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
 

 

R4:
 interface Loopback0
 ip address 10.10.4.4 255.255.255.0
!
interface Loopback1
 ip address 10.4.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.4.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.4.3.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.10.34.4 255.255.255.0
 duplex auto
 
 router eigrp 100
 network 0.0.0.0
 no auto-summary

 

验证:

1、distribute-list 在OSPF进程下的in interface方向,只过滤入口路由并只影响本身的路由,但并不过滤LSA

 在使用distribute-list前,R2上的LSA:

R2#sh ip os da

            OSPF Router with ID (10.10.2.2) (Process ID 100)

                               Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.3.0        10.10.2.2       448         0x80000006 0x0082C1 0
10.10.3.0       10.10.2.2       448         0x80000006 0x003A04 0
10.10.4.0       10.10.2.2       448         0x80000006 0x002F0E 0
10.10.34.0      10.10.2.2       448         0x80000006 0x00E33B 0
10.11.1.1       10.10.1.1       2           0x80000001 0x00145F 0
10.12.1.1       10.10.1.1       2           0x80000001 0x00086A 0
10.13.1.1       10.10.1.1       212         0x80000005 0x00F379 0
应用distribute-list后:

R2路由表中已经没有10.11.1.1和10.12.1.1的路由条目了

R2(config-router)#do sh ip route os
     10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
O       10.10.3.3/32 [110/11] via 10.10.23.3, 00:00:11, FastEthernet0/1
O       10.10.1.1/32 [110/11] via 10.10.12.1, 00:00:11, FastEthernet0/0
O E2    10.13.1.1/32 [110/20] via 10.10.12.1, 00:00:11, FastEthernet0/0
R2(config-router)#

R2中的OSPF数据库中还有相关LSA

R2(config-router)#do sh ip os da

 
                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.3.0        10.10.2.2       117         0x80000002 0x008ABD 0
10.10.3.0       10.10.2.2       117         0x80000002 0x0042FF 0
10.10.4.0       10.10.2.2       117         0x80000002 0x00370A 0
10.10.34.0      10.10.2.2       117         0x80000002 0x00EB37 0
10.11.1.1       10.10.1.1       1507        0x80000001 0x00145F 0
10.12.1.1       10.10.1.1       1508        0x80000001 0x00086A 0
10.13.1.1       10.10.1.1       1519        0x80000003 0x00F777 0
R2(config-router)#

R3上还有相关路由条目和LSA

R3(config-router)#do sh ip route os
     10.0.0.0/8 is variably subnetted, 14 subnets, 2 masks
O       10.10.2.2/32 [110/11] via 10.10.23.2, 00:01:51, FastEthernet0/0
O       10.10.1.1/32 [110/21] via 10.10.23.2, 00:01:51, FastEthernet0/0
O E2    10.11.1.1/32 [110/20] via 10.10.23.2, 00:01:51, FastEthernet0/0
O E2    10.12.1.1/32 [110/20] via 10.10.23.2, 00:01:51, FastEthernet0/0
O E2    10.13.1.1/32 [110/20] via 10.10.23.2, 00:01:51, FastEthernet0/0
O       10.10.12.0/24 [110/20] via 10.10.23.2, 00:01:51, FastEthernet0/0
R3(config-router)#

R3(config-router)#do sh ip os da

 
                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.3.0        10.10.2.2       142         0x80000002 0x008ABD 0
10.10.3.0       10.10.2.2       142         0x80000002 0x0042FF 0
10.10.4.0       10.10.2.2       142         0x80000002 0x00370A 0
10.10.34.0      10.10.2.2       142         0x80000002 0x00EB37 0
10.11.1.1       10.10.1.1       1532        0x80000001 0x00145F 0
10.12.1.1       10.10.1.1       1533        0x80000001 0x00086A 0
10.13.1.1       10.10.1.1       1544        0x80000003 0x00F777 0
R3(config-router)#

 
2、distribute-list 在OSPF进程下的out方向,过滤LSA,路由表从本路由器开始受到影响

distribute-list在R1的OSPF进程下应用前,R1上有10.11.1.1和10.12.1.1的LSA

R1(config-router)#do sh ip os da


                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.3.0        10.10.2.2       206         0x80000002 0x008ABD 0
10.10.3.0       10.10.2.2       206         0x80000002 0x0042FF 0
10.10.4.0       10.10.2.2       206         0x80000002 0x00370A 0
10.10.34.0      10.10.2.2       206         0x80000002 0x00EB37 0
10.11.1.1       10.10.1.1       1594        0x80000001 0x00145F 0
10.12.1.1       10.10.1.1       1595        0x80000001 0x00086A 0
10.13.1.1       10.10.1.1       1606        0x80000003 0x00F777 0
R1(config-router)#

distribute-list在R1的OSPF进程下应用后,R1上没有10.11.1.1和10.12.1.1的LSA

R1(config-router)#do sh ip os da

                  Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.3.0        10.10.2.2       244         0x80000002 0x008ABD 0
10.10.3.0       10.10.2.2       244         0x80000002 0x0042FF 0
10.10.4.0       10.10.2.2       244         0x80000002 0x00370A 0
10.10.34.0      10.10.2.2       244         0x80000002 0x00EB37 0
10.13.1.1       10.10.1.1       1643        0x80000003 0x00F777 0
R1(config-router)#

distribute-list在R2的OSPF进程下应用后,R2上也没有10.11.1.1和10.12.1.1的LSA

R2(config-router)#do sh ip os da

                       Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.3.0        10.10.2.2       265         0x80000002 0x008ABD 0
10.10.3.0       10.10.2.2       265         0x80000002 0x0042FF 0
10.10.4.0       10.10.2.2       265         0x80000002 0x00370A 0
10.10.34.0      10.10.2.2       265         0x80000002 0x00EB37 0
10.13.1.1       10.10.1.1       1667        0x80000003 0x00F777 0
R2(config-router)#

distribute-list在R1的OSPF进程下应用后,R2上也没有10.11.1.1和10.12.1.1的路由条目

R2(config-router)# do sh ip route os
     10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
O       10.10.3.3/32 [110/11] via 10.10.23.3, 00:01:32, FastEthernet0/1
O       10.10.1.1/32 [110/11] via 10.10.12.1, 00:01:32, FastEthernet0/0
O E2    10.13.1.1/32 [110/20] via 10.10.12.1, 00:01:32, FastEthernet0/0
R2(config-router)#

3、在路由进程下使用route-map时,过滤LSA,路由表从本路由器开始受到影响


route-map在R2的OSPF进程下的重发布时应用前,R2上有10.4.1.0和10.4.2.0的LSA

R2(config-router)#do sh ip os da

                           Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.1.0        10.10.2.2       2           0x80000001 0x00A2A8 0
10.4.2.0        10.10.2.2       2           0x80000001 0x0097B2 0
10.4.3.0        10.10.2.2       2           0x80000001 0x008CBC 0
10.10.3.0       10.10.2.2       2           0x80000001 0x0044FE 0
10.10.4.0       10.10.2.2       2           0x80000005 0x00310D 0
10.10.34.0      10.10.2.2       3           0x80000005 0x00E53A 0
10.13.1.1       10.10.1.1       1772        0x80000003 0x00F777 0
R2(config-router)#

route-map在R2的OSPF进程下的重发布时应用前,R1上有10.4.1.0和10.4.2.0的LSA

R1(config-router)#do sh ip os da

  

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.1.0        10.10.2.2       32          0x80000001 0x00A2A8 0
10.4.2.0        10.10.2.2       32          0x80000001 0x0097B2 0
10.4.3.0        10.10.2.2       26          0x80000005 0x0084C0 0
10.10.3.0       10.10.2.2       26          0x80000005 0x003C03 0
10.10.4.0       10.10.2.2       26          0x80000005 0x00310D 0
10.10.34.0      10.10.2.2       27          0x80000005 0x00E53A 0
10.13.1.1       10.10.1.1       1795        0x80000003 0x00F777 0
R1(config-router)#

route-map在R2的OSPF进程下的重发布时应用前,R2上有10.4.1.0和10.4.2.0的路由条目

R1#sh ip route os
     10.0.0.0/8 is variably subnetted, 14 subnets, 2 masks
O       10.10.3.3/32 [110/21] via 10.10.12.2, 00:06:44, FastEthernet0/1
O       10.10.2.2/32 [110/11] via 10.10.12.2, 00:06:44, FastEthernet0/1
O E2    10.10.3.0/24 [110/20] via 10.10.12.2, 00:01:30, FastEthernet0/1
O E2    10.10.4.0/24 [110/20] via 10.10.12.2, 00:01:30, FastEthernet0/1
O E2    10.4.2.0/24 [110/20] via 10.10.12.2, 00:01:34, FastEthernet0/1
O E2    10.4.3.0/24 [110/20] via 10.10.12.2, 00:01:30, FastEthernet0/1
O E2    10.4.1.0/24 [110/20] via 10.10.12.2, 00:01:34, FastEthernet0/1

当有如下route-map在R2的OSPF进程下的重发布时应用时,R2上没有了10.4.1.0和10.4.2.0的LSA

Standard IP access list deny-eigrp
    10 deny   10.4.1.0, wildcard bits 0.0.0.255 
    20 deny   10.4.2.0, wildcard bits 0.0.0.255

    30 permit any     
    route-map deny-eigrp permit 10
 match ip address deny-eigrp
 
 R2(config-router)#do sh ip os da

                      Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.3.0        10.10.2.2       161         0x80000005 0x0084C0 0
10.10.3.0       10.10.2.2       161         0x80000005 0x003C03 0
10.10.4.0       10.10.2.2       161         0x80000005 0x00310D 0
10.10.34.0      10.10.2.2       161         0x80000005 0x00E53A 0
10.13.1.1       10.10.1.1       1930        0x80000003 0x00F777 0
R2(config-router)#

route-map在R2的OSPF进程下的重发布时应用前,R2上没有10.4.1.0和10.4.2.0的路由条目

R1#sh ip route os
     10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
O       10.10.3.3/32 [110/21] via 10.10.12.2, 00:08:15, FastEthernet0/1
O       10.10.2.2/32 [110/11] via 10.10.12.2, 00:08:15, FastEthernet0/1
O E2    10.10.3.0/24 [110/20] via 10.10.12.2, 00:03:00, FastEthernet0/1
O E2    10.10.4.0/24 [110/20] via 10.10.12.2, 00:03:00, FastEthernet0/1
O E2    10.4.3.0/24 [110/20] via 10.10.12.2, 00:03:00, FastEthernet0/1
O       10.10.23.0/24 [110/20] via 10.10.12.2, 00:08:15, FastEthernet0/1
O       10.10.34.0/24 [110/30] via 10.10.12.2, 00:08:15, FastEthernet0/1
R1#

route-map在R2的OSPF进程下的重发布时应用前,R2上也没有了10.4.1.0和10.4.2.0的LSA

R1#sh ip  os da

            OSPF Router with ID (10.10.1.1) (Process ID 100)

                        Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.4.3.0        10.10.2.2       197         0x80000005 0x0084C0 0
10.10.3.0       10.10.2.2       197         0x80000005 0x003C03 0
10.10.4.0       10.10.2.2       197         0x80000005 0x00310D 0
10.10.34.0      10.10.2.2       197         0x80000005 0x00E53A 0
10.13.1.1       10.10.1.1       1965        0x80000003 0x00F777 0
R1#


 注:在实际使用中到底是使用route-map还是使用distribute-list根据实际情况使用。

  评论这张
 
阅读(3317)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017